QA Forums
Welcome on the QA Forums.

To take full advantage of everything offered by our software testing & Quality forums, please log in if you are already a member or join our community if you're not yet.... Smile
Search
 
 

Display results as :
 


Rechercher Advanced Search

Navigation
 Portal
 Index
 Memberlist
 Profile
 FAQ
 Search
Who is online?
In total there is 1 user online :: 0 Registered, 0 Hidden and 1 Guest

None

[ View the whole list ]


Most users ever online was 35 on Tue Sep 23, 2014 10:22 pm
November 2017
MonTueWedThuFriSatSun
  12345
6789101112
13141516171819
20212223242526
27282930   

Calendar Calendar


Recording with OpenSTA

View previous topic View next topic Go down

Recording with OpenSTA

Post  Pogo on Thu Oct 07, 2010 11:28 pm

Hi,

I'm trying to use OpenSTA to test a simple application. Below are the steps that I'm following:

1. Open OpenSTA Commander.
2. Click on File >> New HTTP Script.
3. Double click the script name and I got ScriptModeler.
4. Then, I changed the browser into Internet Explorer 6 and in gateway I selected Local, and only changed port into 8080, the rest remained the same.
5. In Internet Explorer, I put proxy server and 8080 port and it is working.

After setting all these I clicked on Record button, at this point I keep getting a warning window saying "You have not specified to go through proxy in your internet settings. It is compulsory to make a capture".

Thus, I'm not able to do recording. I did specify proxy in Internet Explorer options but I'm not able to find why OpenSTA does not allow recording.

Please help me with this problem.

Thanks.

Pogo

Posts : 11
Reward Points : 23
Join date : 2010-09-13

View user profile

Back to top Go down

Re: Recording with OpenSTA

Post  yadav on Thu Oct 07, 2010 11:30 pm

Do not change the port numbers in IE and the gateway. They would work fine with their default values.

I also follow the steps that you described in your post, there is no error. I'm able to do recording.

However, try the following steps:

1. Set the gateway port to 8080
2. Start a recording
3. After IE starts, in IE go to Tools > InternetOptions > Connections > LanSettings

Here, you should see a box checked for "Use a proxy server for your LAN", set the address box to "YOURCOMPUTERNAME" and port number as 8080.

Now, try to start recording. You must be able to perform your testing now.

yadav

Posts : 12
Reward Points : 30
Join date : 2010-09-13

View user profile

Back to top Go down

Re: Recording with OpenSTA

Post  Pogo on Thu Oct 07, 2010 11:31 pm

Thanks yadav for your reply !!

I installed OpenSTA on another laptop and it is working in that laptop.

I just changed the Internet Explorer LAN settings:
- Port number 81
- Proxy address to be localhost.

One of my friends told me that with such settings it is possible only to record application which is running locally. Is it really true ? If so, then how to test web applications that run on internet.

Also, please tell me some basic OpenSTA tutorial

Thanks in advance.
P

Pogo

Posts : 11
Reward Points : 23
Join date : 2010-09-13

View user profile

Back to top Go down

Re: Recording with OpenSTA

Post  puneet on Thu Oct 07, 2010 11:32 pm

See "Getting started guide":

http://www.opensta.org/docs/ug/

It is very useful tutorial of OpenSTA for doing a basic Performance Test. When I started my carrier as a Performance Tester, I refer to it.

Best Regards & Good Luck.
Puneet..

puneet

Posts : 21
Reward Points : 41
Join date : 2010-08-22

View user profile

Back to top Go down

Re: Recording with OpenSTA

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum